Oculus Extension with FE 2.1

Hi everybody,
I am trying to use the Oculus Plugin in Fabric Engine 2.1, but I get a bunch of warnings and errors.

How can I compile the extension against version 2.1? Or is there anything else I am doing wrong?

Any ideas are highly appreciated!

Comments

  • borjaborja Administrator, Fabric Employee Posts: 480 admin

    Hi @laschmoove

    C++ extensions built against a specific major version require to be rebuilt for the next major release.
    In this particular case, the Oculus extension was built against 2.0.0 and it requires a recompilation against 2.1.0.
    There are build instructions in the Oculus Extension repository
    https://github.com/fabric-engine/Oculus
    But I will check with the developer to see if it is possible to update the extension binaries to 2.1.0

    Thanks for your patience!

    Borja Morales
    Technical Product Manager
    Fabric Software Inc.

  • xanderxenxanderxen Posts: 22

    Has anyone successfully compiled the Oculus extension for Fabric Engine 2.1? There is also a new Oculus SDK version (the non-beta release) currently V1.3.0. Has anyone attempted compiling against that?

Sign In or Register to comment.