It looks like you're new here. If you want to get involved, click one of these buttons!
I really like blocks... but there is a problem with the naming.
In the current version, "Block" is used for two very different things:
The distinction can be found in the API, with ExecBlock ans InstBlock.
Following Java naming, the 1st one is Block Interface and second one is Block Implementation. Or it can be Block Template and Block instance... whatever, but I really thing the whole concept will benefit with a different name for the two concepts.
And one question: what is the plan for porting Block to PEX. As far as I see it, you will have to annotate all presets as PEX compatible or not. Or let the user decide and create PEX Block Instance...
Blocks are really a huge step forward... changing the name is not mandatory of course, but it will make think clearer, easier to understand.
©Copyright 2017 Fabric Software Inc. All rights reserved. | Privacy