Fabric Engine crashing with a Qt Library error

cgarjuncgarjun Posts: 1
edited October 2016 in Canvas Standalone

When I click on the save graph or load graph button Fabric Engine simply crashes with the error below, Am on a centOS 7

Cannot mix incompatible Qt library (version 0x40805) with this library (version 0x40807)
/usr/local/FabricEngine-2.3.0-Linux-x86_64/canvas.sh: line 9:   358 Aborted                 (core dumped) python $BASEDIR/bin/canvas.py
Tagged:

Comments

  • borjaborja Administrator, Fabric Employee Posts: 470 admin

    Hi @cgarjun

    Mind checking if it happens the same if you ran canvas instead of canvas.py (to do this open the terminal, go to the Fabric folder, execute "source environment.sh" then execute canvas.
    Can you also go to the bin folder, execute the command ldd canvas and copy and paste the output content here?.

    Thanks!

    Borja Morales
    Technical Product Manager
    Fabric Software Inc.

  • jprynejpryne Posts: 10
    edited March 17

    @borja said:
    Hi @cgarjun

    Mind checking if it happens the same if you ran canvas instead of canvas.py (to do this open the terminal, go to the Fabric folder, execute "source environment.sh" then execute canvas.
    Can you also go to the bin folder, execute the command ldd canvas and copy and paste the output content here?.

    Thanks!

    In this case, is "source" a part of GitBash? I'm using GitHub, but "source" is not recognized.

  • borjaborja Administrator, Fabric Employee Posts: 470 admin

    Borja Morales
    Technical Product Manager
    Fabric Software Inc.

Sign In or Register to comment.