How to install multipede in User folder?

Hi guys,

Thanks for the great production example! I'd like to take a closer look, but can't install it into the fabric installation directory (I don't have the necessary permissions).

Is there a way to install the multipede extensions using the User folder instead? When I copy the contents of the zip file into the User folder the DFG presets show up, but as soon as I drag any of them into canvas they get a red frame and produce error messages (here for the "ModifyInPlace" block):
ModifyInPlace_1 - 'Multipede': 'Multipede' type not registered
ModifyInPlace_1.ForLoop_1 - index 1: port 'multipede': 'defaultValues': 'Multipede': type not registered
ModifyInPlace_1.body.body - 'MultipedeSegment': 'MultipedeSegment':type not registered

Any ideas?

Thanks,
-Markus

ps: is there an easy way to copy and paste error-messages from canvas (Maya)?

Tagged:

Best Answers

Answers

  • MarkusDMarkusD Posts: 3

    Thanks Marc! Adding my user folder to the FABRIC_EXTS_PATH and copying the whole "ProductionSamples" folder to it did the trick.

    I'm just a little confused about one thing. At first I tried to separate the extension files from the canvas presets. So I copied the extension file into one folder (Multipede.kl), which I added to the FABRIC_EXTS_PATH, and the presets into another, which I added to the FABRIC_EXTS_PATH.

    Fabric found and displayed the presets properly in canvas, but it couldn't find the extension file. Only when I copied the whole "ProductionSamples" folder (including the extensions AND the presets) to the user folder that was added to the FABRIC_EXTS_PATH, it suddenly worked. Do you have an explanation for this? Somehow it seems that the path in which the extension file lives is important for fabric. I assume it has something to do with how the presets, that use these extensions, are registered? I couldn't figure out, how exactly this works. Would you be able to point me into the right direction?

    Thanks,
    -Markus

  • MarkusDMarkusD Posts: 3

    Thanks again, Marc!

Sign In or Register to comment.